Marantz 250M no sound.

Discussion in 'Marantz Audio' started by gogofast, Feb 12, 2019.

  1. gogofast

    gogofast AK Subscriber Subscriber

    Messages:
    8,052
    Location:
    Seattle
    I have a recapped 250M that sounded so great with amazing dynamics after a recap and output replacements. After a few months using it, it all of a sudden developed a loud intermittent pop. So, I just put it away and used a different power amp. Today, I had some extra time, so I opened the amp up and looked for possible cause for that loud pop which on closer listen, was a sizzling and pop. The pop will cause the amp to shut off sound for a few seconds and then the relay will click again and sound came back on its own.

    While taking out the boards, I realized that 3 pin connection to the heatsink on the problem channel wasn't making full contact.

    Straightened the pins and reconnected. The problem was gone! I was listening for 30 minutes. while I was moving the speaker wires, I heard a faint sizzle/hiss and then the sound cut off on both channels. I'm not sure if I momentarily disconnected the speaker wires or stepped on a extension cord to disconnect the power momentarily and back on. Anyways, the relay does not click and no sound.

    Any ideas of what might've happened? After all those loud pops before fixing the issue, do you think that might've done something to the relay? I'll measure the DC offset tomorrow, but considering the above explanation of what happened, any idea what might've happened?

    Thanks.
     

     

    Please register to disable this ad.

  2. mbz

    mbz Super Member

    Messages:
    2,444
    Location:
    Melbourne, Victoria
    Text book shorted output transistors and possibly supporting components (emitter resistors? drivers???) fiddling with speaker
    wires while the amp is powered ON.

    Certainly check for any dc voltage on the speaker line, check at pin 19 on the power amp board or pins 5 and 7 on the
    relay board, black probe connected to chassis for all measurements. Don't measure at speaker posts since relay is open.
    Hopefully all will be well, nice amp...
     
    quadmatrix82 and gogofast like this.
  3. gogofast

    gogofast AK Subscriber Subscriber

    Messages:
    8,052
    Location:
    Seattle
    Yeah, I was just moving the wires to the back....only thing I don't like about the 250M is the narrow speaker terminals with just screws. Thanks for the advice!
     

Share This Page